New guy here, Having an issue with his K6-2+

Off topic chat and stuff that doesn't fit elsewhere.
Post Reply
Newbie K6'er
Posts: 3
Joined: Sat Jun 18, 2011 5:50 pm

New guy here, Having an issue with his K6-2+

Post by Angry » Sat Jun 18, 2011 5:57 pm

Hey guys, Ive been playing with the following system:

K6-2+ 570AHZ @ 660mhz
2x256mb of ram
120gb Maxtore ATA133

My problem stems from trying to run a Geforce 5900 Ultra, the card works fine, Ive tested it in another system. The problem is when I try to run anything 3d, (even the Nvidia 3d rotating logo in the driver nvidia control panel) It will either restart or bluescreen on me, no matter what.

A ATi Rage 128 pro 32mb works just fine...but slow as molasses.

using the last 175.xx drivers for the 5900 Ultra in Windows XP.

Newbie K6'er
Posts: 3
Joined: Sat Jun 18, 2011 5:50 pm

Post by Angry » Sat Jun 18, 2011 6:30 pm

Oops, meant to post this in a different section. My bad guys.

Newbie K6'er
Posts: 3
Joined: Sat Jun 18, 2011 5:50 pm

Post by Angry » Sat Jun 18, 2011 6:34 pm

Woot! Found my answer here in the forums..
goodneit wrote:Buyer beware: If you're looking to purchase and install an nVidia graphics card in an attempt to breathe new life into an older Socket 7-based system, you will likely run into problems with the supplied drivers, particularly if you play DirectX 3-D games.

My experiences were the exactly the same as those reported on here by DonPedro.

My setup is a PCI inplementation of the GeForce FX-5200 graphics card installed in a VIA Apollo MVP3 chipset motherboard (no AGP slot) running a K6-3 processor.

In addition to receiving errors when attempting to play DirectX games, I noticed that Microsoft's DxDiag utility aborted when it got to the "spinning cube" portion of the test designed to test Direct 3-D in DX8 mode. Attempting to rerun the same test yielded a message stating that Direct 3-D functionality wasn't available (the Test Direct3D button was greyed out).

I tried installing nVidia driver versions 61.76 and 81.98 under both Windows 98 and ME (81.98 is reported to be the last driver version which works with these operating systems). I also did a fresh install of Windows XP and loaded (current) nVidia driver version 175.19. Each test iteration resulted in the same DirectX 3-D anomaly. I then reloaded each operating system (98, ME, XP), installed an older driver version (56.65), and re-ran the Direct X tests. To my surprise, driver version 56.65 worked flawlessly for each of the three operating systems.

So the bottom line is that if you do install an nVidia graphics card in one of these older systems, you may want to install an older driver version. I found v56.65 on
Freaking works like a charm! v56.64 to be exact!
Got them from here:

Newbie K6'er
Posts: 22
Joined: Fri Jun 10, 2011 11:00 pm
Location: Mexico

Post by mikemex » Sat Jun 18, 2011 9:16 pm


A big issue with K6 series processors is that they are almost, but not entirely, i686 compatible. They lack CMOV instructions. At this point, manufacturers doesn't bother to check if the processor is i686 compatible; they simply assume that all processors in use today are compatible.

You must be very careful installing modern software on such machines. There is a lot of poorly enginered software around that doesn't work properly. This is only going to get worse over time, so you better start to compile a tested software base if you plan to keep your system for long.

By the way, video card selection depends on a lot of things besides raw performance. I certainly don't expect a system like this to be a gaming machine; for me a Rage 128 Pro is more attractive than a GeForce 5900 because it offers hardware motion compensation and inverse discrete cosine transformation which offloads the CPU in DVD playing, which is an application a system like this would be very good at. It's very difficult to see movies in a Socket 7 system without a good video card.

User avatar
Veteran K6'er
Posts: 394
Joined: Sat Jun 09, 2001 11:55 am

Post by jsc1973 » Fri Jun 24, 2011 11:57 am

The CMOV issue is starting to be a problem. Last night, I tried to boot Jolicloud on a K6-III+ equipped laptop, after reading their own specs that it should run on any laptop that is 10 years old or less. Unfortunately, the kernel it uses requires this instruction.

About the only things that seem to work, other than Windows, are Puppy and DSL. I understand that instruction isn't all that important, but developers are just assuming everything has it, and compile with CMOV in mind these days.
FIC VA-503+, Rev. 1.2, AMD K6-III+ 450@550MHz, 80GB Seagate ATA-100, 3dfx Voodoo3 3500 TV, TB Montego II Quadzilla, Win98se, 384MB PC100

Compaq Presario 1273, AMD K6-III+ 450@400MHz 1.8v, 40GB Samsung 5400RPM, extremely hacked Win98SE, 288 (yes, 288!) MB RAM
(Also an AMD FX-8350, which does the heavy lifting these days...)

Post Reply